XMM-Newton SAS Home Page
XMM-Newton Science Analysis System


xmmselect (xmmselect-2.67) [xmmsas_20211130_0941-20.0.0]

Menus

At the top of the main window are five pull-down menus labeled File, Column, Region, Viewer, Style, and Help respectively.

The File menu contains the following selectable entries:

field key shortcut purpose
New table Control+N Bring up a data set browser for selecting a new input table. If a new table has been selected the GUI will be re-initialized.
Reload table Control+R Rescan the input table and re-initialize the GUI
Exit Control+X Terminate xmmselect

The Column menu contains the following selectable entries:

field key shortcut purpose
Add new column Control+D Bring up the parameter dialog of tabcalc. If the task has run successfully the table will contain a new column. In this case the table will be rescanned and the GUI re-initialized.
Add PHASE column Control+P Bring up the parameter dialog of phasecalc. If the task has run successfully the table will contain a new column PHASE. In this case the table will be rescanned and the GUI re-initialized.
Delete column Control+L Delete the column from the table that is currently marked to be used in a 1-D product extraction.

The Region menu contains the following selectable entries:

field key shortcut purpose
Union Control+U If selected multiple 2-D image regions are combined with logical or (union)
Intersection Control+I If selected multiple 2-D image regions are combined with logical and (intersection)

The Viewer menu contains the following selectable entries:

field key shortcut purpose
Binned Intensity Image Control+B If selected images are displayed as binned intensity images with the task imgdisplay
Scatter plot image Control+S If selected images are displayed as scatter plots with the task dsplot

The Products menu contains the following selectable entries:

field key shortcut purpose
backscale on spectra Control+C If selected the task backscale is run automatically on all extracted spectra prior to display
high accuracy backscal Control+H If selected the task backscale uses a fine grid to calculate the BACKSCAL value. This can be slow for large areas and turning this off will use a coarser grid that will run faster
eregionanalyse on source image Control+R The generation of OGIP spectral products requires the selection of a source extraction region. If the checkbox is selected the task eregionanalyse will be invoked on the selected region to optimize its centroid and radius before the generation of spectral products is performed.

The Style and Help menus comprise entries which are common to all interactive SAS tasks, e.g. Font to select the font of text label, etc. As a bare minimum the Help menu will always contain at least the following entries:

field key shortcut purpose
Help Control+H Bring up a HTML browser displaying the xmmselect on-line documentation
About Control+A Display a dialog box with general information about xmmselect

XMM-Newton SOC -- 2021-11-30